Show Menu

NET-126 Commands Cheat Sheet by

List of commands for exam prep
commands     cisco     networking     configuration     ios     switch     router

[Router] Basic Config­uration

Short Command
Full­-Length Command
ho R1
hostname R1
no ip dom lo
no ip domain­-lo­okup
ena sec class
enable secret class
ser pass
service password-encryption
banner motd #Authorized access ONLY!#
banner motd #[Tex­t]#
login blo 120 a 3 w 30
login block-for 120 attempts 3 within 30
 
lin con 0
line console 0
pass cisco
password cisco
log­in
login
logg sync
logging synchr­onous
exec-t 5 0
exec-­timeout 5 0
 
lin vty 0 15
line vty 0 15
pass cisco
password cisco
log­in
login
logg sync
logging synchr­onous
exec-t 5 0
exec-­timeout 5 0
 
int g0/0
interface [inte­rfa­ce]
desc Connected to G0/0 on R2
descr­iption [text]
ip add 10.1.1.1 255.255.255.0
ip address [address] [subnet-mask]
no shut
no shutdown
exit
exit

[Switch] Basic Config­uration

Short Command
Full­-Length Command
ho S1
hostname S1
no ip dom lo
no ip domain­-lo­okup
ena sec class
enable secret class
service password-e
service password-encryption
 
lin con 0
line console 0
pass cisco
password cisco
log­in
login
logg sync
logging synchr­onous
exec-t 5 0
exec-­timeout 5 0
 
lin vty 0 15
line vty 0 15
pass cisco
password cisco
log­in
login
logg sync
logging synchr­onous
exec-t 5 0
exec-­timeout 5 0
exit
exit

[Switch] VLAN Config­uration

Short Command
Full­-Length Command
int vl 10
interface vlan [vlan-number]
na Students
name [vlan­-na­me]
exit
exit
 
int f0/5
interface [inte­rfa­ce]
sw m a
switc­hport mode access
sw a v 10
switchport access vlan [vlan-number]
exit
exit

[Switch] Port Security

Short Command
Full­-Length Command
sw port
switchport port-security
sw port max 2
switchport port-security maximum 2
sw port mac st
switchport port-security mac-address sticky
sw port v shut
switc­hport port-s­ecurity violation [mode]
* Only on access ports, not trunking ports!

[Switch] VLAN Trunking

Short Command
Full­-Length Command
int f0/5
interface [inte­rfa­ce]
sw m t
switc­hport mode trunking
sw t n v 30
switchport trunking native vlan 30
sw t a v 10,20,30
switchport trunking access vlan 10,20,30
sw non
switc­hport nonego­tiate

[Route­r/S­witch] SSH Config­uration

Short Command
Full­-Length Command
usern admin sec cisco
username [name] secret [password]
ip dom n ccna-labs.com
ip domain-name [domain]
cry key gen rsa gen mod 1024
crypto key generate rsa general-keys modulus 1024
ip ssh v 2
ip ssh version 2
 
lin vty 0 15
line vty 0 15
login lo
login local
trans in ssh
transport input ssh

Router­-On­-A-­Stick Config­uration

Short Command
Full­-Length Command
int g0/0.10
interface [subi­nte­rfa­ce]
enc dot 10
encapsulation dot1Q [vlan-number]
desc Gateway for Students VLAN
descr­iption [text]
ip add 10.1.2.1 255.255.255.0
ip address [address] [subnet-mask]
 
int g0/0.20
interface [subi­nte­rfa­ce]
enc dot 20
encapsulation dot1Q [vlan-number]
desc Gateway for Faculty VLAN
descr­iption [text]
ip add 10.1.3.1 255.255.255.0
ip address [address] [subnet-mask]
exit
exit
 
int g0/0
interface [inte­rfa­ce]
no shut
no shutdown
exit
exit

RIP Config­uration

Short Command
Full­-Length Command
ip route 0.0.0.0 0.0.0.0 s0/0/0
ip route 0.0.0.0 0.0.0.0 [exit-interface]
router rip
router rip
ver 2
version 2
no auto
no auto-s­ummary
net 192.16­8.1.0
network [netw­ork­-ad­dre­ss]
pa g0/0
passi­ve-­int­erface [inte­rfa­ce]
* def o
defau­lt-­inf­orm­ation originate
* Only on router connected to internet
exit
exit

DHCP Config­uration

Short Command
Full­-Length Command
--- DHCP Server ---
ip dhcp ex 192.168.1.1 192.168.1.5
ip dhcp excluded-address [first-IP] [last-IP]
ip dhcp pool R1_Pool
ip dhcp pool [pool­-na­me]
netw 192.16­8.1.0 255.25­5.2­55.0
network [network-address] [subnet-mask]
def 192.16­8.1.1
defau­lt-­router [defa­ult­-ga­tew­ay-­IP]
exit
exit
 
--- Relay Router ---
int g0/0
interface [inte­rfa­ce]
ip dhcp help [serv­er-­IP]
ip dhcp helper­-ad­dress [serv­er-­IP]
exit
exit

NAT Config­uration

Short Command
Full­-Length Command
acc s 10 p 192.16­8.1.0
access-list standard [acl-number] permit [address]
ip nat pool CorpNet 209.165.200.10
209.165.200.13 net 255.255.255.0
ip nat pool [pool-name] [first-IP] [last-IP] network [subnet-mask]
ip nat in s list 10 pool CorpNet ov
ip nat inside source list [acl-number] pool [pool-name] overload
int g0/0
interface [inte­rfa­ce]
ip nat in
ip nat inside
int s0/0/0
interface [inte­rfa­ce]
ip nat out
ip nat outside
exit
exit

Download the NET-126 Commands Cheat Sheet

4 Pages
//media.cheatography.com/storage/thumb/tamaranth_net-126-commands.750.jpg

PDF (recommended)

Alternative Downloads

Share This Cheat Sheet!

 

Comments

No comments yet. Add yours below!

Add a Comment

Your Comment

Please enter your name.

    Please enter your email address

      Please enter your Comment.

          Related Cheat Sheets

          Cisco Switch Configuration Cheat Sheet

          More Cheat Sheets by Tamaranth

          Cisco Device Security Cheat Sheet
          Cisco Switch Configuration Cheat Sheet