Show Menu

Cisco Device Configuration Commands (NET-126) Cheat Sheet by

commands     intermediate     cisco     networking     network     configuration     ios     switch     router

General Config­ura­tions

Comm­and
Mode
Func­tion
terminal history size 200
priv. EXEC
changes how many commands the history buffer stores (for this session only)

Dynamic Routing Protocol Config­uration

Comm­and
Mode
Func­tion
router [protocol]
global
enables protocol & enters router config mode
aut­o-s­umm­ary
router
enables automatic network # summar­ization
default-information originate
router
advertises default route info
network [ip-address]
router
enables dynamic routing for the network
(Directly connected nets only!)
network [ip-address] area 0
router
assigns network to area 0
passive-interface g0/1
router
disables routing updates on that interface
ver­sion [version]
router
sets protocol version

DHCP Config­uration

Comm­and
Mode
ip dhcp excluded-address [first IP] [last ip]
global
ip dhcp pool R1G1
global
net­work [network IP] [subnet mask]
(dhcp-­config)
def­aul­t-r­outer [gateway IP]
(dhcp-config)
dns­-se­rver [dns IP]
(dhcp-­config)
dom­ain­-name ccna-l­ab.com
(dhcp-­config)
lease 2
(dhcp-­config)
ip dhcp helper­-ad­dress [dhcp server IP]
interface (on relay router)

NAT Config­uration

Short Command
Full Command
What It Does
ip nat pool name
[first IP] [last IP]
net [subnet mask]
ip nat pool name
[first IP] [last IP]
netmask [subnet mask]
defines the pool of public addresses to use
ip nat in s l 10
pool name ov
ip nat inside source list
[acl#] pool name overload
enables PAT & specifies which ACL is being translated to which NAT pool
ip nat in
ip nat inside
identifies inside interface
(int config)
ip nat out
ip nat outside
identifies outside interface
(int config)
ip nat in s st
192.168.1.10 209.165.200.18
ip nat inside source static
[private IP] [global IP]
configures static NAT mapping
----- Show Commands -----
sh ip nat s
show ip nat statis­tics
sh ip nat t
show ip nat transl­ati­ons

Trunking & Subint­erfaces

Comm­and
Mode
enc­aps­ulation dot1Q
 

Routing Table

Comm­and
Mode
Func­tion
interface loopback 0
global
loopback address configuration
ip route [network] [subnet] [exit-int|next-hop]
ipv6 route [network/prefix] [exit-int|next-hop]
global
configs a static route
ip route 0.0.0.0 0.0.0.0 [exit-int]
ipv6 route ::/0 [exit-int]
global
sets default static route
ip route 0.0.0.0 0.0.0.0 [next-hop] [AD]
ipv6 route ::/0 [next-hop] [AD]
global
configs a floating static route

New Show Commands

Short Command
What It Displays
sh run int g0/0
running config for specified interface
sh run | [begin|include|exclude|section] line vty
filtered runnin­g-c­onfig output
sh history
contents of history buffer (previ­ously entered commands)
sh ip protoc­ols
dynamic routing protocol settings

Refresher Commands: General

Short Command
Complete Command
Mode
no ip dom lo
no ip domain­-lo­okup
global
login blo 120 a 3 w 60
login block-for 120 attempts 3 within 60
global
security pass min 8
security password min-length 8
global
exe­c-t­imeout 10
exec-­timeout 10
line

Refresher Commands: Enabling SSH

Short Command
Complete Command
Mode
ip dom n CCNA-lab.com
ip domain­-name CCNA-l­abs.com
global
cry key gen rsa gen mod 1024
crypto key generate rsa general-keys
modulus 1024
global
user Bob sec cisco
username Bob secret cisco
global
login lo
login local
line
trans in ssh
transport input ssh
line
ip ssh v 2
ip ssh version 2
global

Download the Cisco Device Configuration Commands (NET-126) Cheat Sheet

2 Pages
//media.cheatography.com/storage/thumb/tamaranth_cisco-device-configuration-commands-net-126.750.jpg

PDF (recommended)

Alternative Downloads

Share This Cheat Sheet!

 

Comments

No comments yet. Add yours below!

Add a Comment

Your Comment

Please enter your name.

    Please enter your email address

      Please enter your Comment.

          Related Cheat Sheets

          NET-126 Commands Cheat Sheet
          Cisco Switch Configuration Cheat Sheet
          Basic Cisco IOS Commands Cheat Sheet

          More Cheat Sheets by Tamaranth

          Minecraft Item IDs Cheat Sheet